Quantcast

Los acentos causan problemas en Editar/Propietario

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Los acentos causan problemas en Editar/Propietario

Raul Ross Pineda

Hola Colegas

He estado revisando Plone 5, en español, porque estoy trabajando en la actualización del manual de Plone 4 que compartí con ustedes hace aproximadamente un par de años.

En mis ejercicios me encontré con un par de problemas relacionados que parecen ser bugs. A continuación los describo para que alguien los reporte a Plone o me brinde alguna solución.

1) En la /Barra de actividades/Editar/Propietario/ usé el campo Creadores para escribir mi nombre (Raúl Ross) y guardé el formulario. El elemento en que estaba trabajando se puede visualizar sin problema (sin mi firma, pues no he habilitado esta funcionalidad en el tablero de configuración); pero al tratar de editarlo (haciendo clic en Barra de actividades/Editar) me aparece el siguiente mensaje de error.

Traceback (innermost last):

  Module ZPublisher.Publish, line 138, in publish
  Module ZPublisher.mapply, line 77, in mapply
  Module ZPublisher.Publish, line 48, in call_object
  Module plone.z3cform.layout, line 66, in __call__
  Module plone.z3cform.layout, line 60, in update
  Module z3c.form.form, line 161, in render
  Module zope.browserpage.viewpagetemplatefile, line 51, in __call__
  Module zope.pagetemplate.pagetemplate, line 132, in pt_render
  Module five.pt.engine, line 93, in __call__
  Module z3c.pt.pagetemplate, line 163, in render
  Module chameleon.zpt.template, line 258, in render
  Module chameleon.template, line 171, in render
  Module a6196370eeef16bdfeffd7a1f6c2c3fc.py, line 91, in render
  Module 84010745d9849206617ac146e07c7d09.py, line 1801, in render_titlelessform
  Module 84010745d9849206617ac146e07c7d09.py, line 810, in render_fields
  Module 84010745d9849206617ac146e07c7d09.py, line 126, in render_widget_rendering
  Module 84010745d9849206617ac146e07c7d09.py, line 1069, in render_field
  Module five.pt.expressions, line 161, in __call__
  Module Products.Five.browser.metaconfigure, line 485, in __call__
  Module zope.browserpage.viewpagetemplatefile, line 83, in __call__
  Module zope.browserpage.viewpagetemplatefile, line 51, in __call__
  Module zope.pagetemplate.pagetemplate, line 132, in pt_render
  Module five.pt.engine, line 93, in __call__
  Module z3c.pt.pagetemplate, line 163, in render
  Module chameleon.zpt.template, line 258, in render
  Module chameleon.template, line 191, in render
  Module chameleon.template, line 171, in render
  Module f299509b288dcc3b86da17d9fd37611b.py, line 591, in render
  Module f299509b288dcc3b86da17d9fd37611b.py, line 466, in render_widget_wrapper
  Module five.pt.expressions, line 161, in __call__
  Module plone.app.z3cform.widget, line 86, in render
  Module plone.app.z3cform.widget, line 331, in _base_args
  Module plone.app.widgets.utils, line 116, in get_ajaxselect_options
  Module plone.app.vocabularies.users, line 98, in getTerm
  Module zope.schema.vocabulary, line 41, in __init__
UnicodeEncodeError: 'ascii' codec can't encode character u'\xfa' in position 2: ordinal not in range(128)

 - Expression: "widget/@@ploneform-render-widget"
 - Filename:   ... rm-1.1.5-py2.7.egg/plone/app/z3cform/templates/macros.pt
 - Location:   (line 98: col 81)
 - Source:     ... place="structure widget/@@ploneform-render-widget"/>
                                    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
 - Expression: "widget/render"
 - Filename:   ... rm-1.1.5-py2.7.egg/plone/app/z3cform/templates/widget.pt
 - Location:   (line 38: col 46)
 - Source:     ... xt" tal:replace="structure widget/render"
                                              ^^^^^^^^^^^^^
 - Arguments:  repeat: {...} (0)
               context: <AjaxSelectWidget IDublinCore.contributors at 0x7f0eeb745e10>
               views: <ViewMapper - at 0x7f0eeb745150>
               modules: <TraversableModuleImporter - at 0x7f0ef46515d0>
               args: <tuple - at 0x7f0efc245050>
               nothing: <NoneType - at 0x91a870>
               target_language: <NoneType - at 0x91a870>
               default: <object - at 0x7f0efc164500>
               request: <instance - at 0x7f0eecc41ab8>
               wrapped_repeat: {...} (0)
               loop: {...} (0)
               template: <ViewPageTemplateFile - at 0x7f0eed128990>
               translate: <function translate at 0x7f0eeb092758>
               options: {...} (0)
               view: <RenderWidget ploneform-render-widget at 0x7f0eeb745ad0>


Aunque no entiendo exactamente en qué consiste el error, tengo la seguridad de que el problema lo provoca la vocal acentuada porque repetí este ejercicio en otros elementos y obtuve el mismo mensaje de error. El mismo problema se repite cuando escribo una vocal acentuada en el campo Colaboradores.

2) Usé el Histórico para revertir mi elemento dañado a una versión anterior y el resultado fue el mismo: se puede visualizar sin problema; pero, al tratar de editarlo me aparece el mismo mensaje de error. Así que tampoco me funcionó en este caso el mecanismo de recuperación de versiones previas.


--
Saludos,
Raul Ross Pineda

_______________________________________________
Usuarios-Plone mailing list
[hidden email]
https://lists.plone.org/mailman/listinfo/plone-usuarios-plone
Loading...